Welcome Guest ( Login | Register )



All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Micrologix Ethernet Problem
PostPosted: Thu Feb 07, 2013 4:55 pm 

Joined: Tue Oct 30, 2012 8:33 pm
Posts: 15

Offline
Hi,
We are developing an HMI application using an iX-T12C connected to a Micrologix 1500 via a Allen-Bradley DF1 to Ethernet/IP adapter. We are using the Micrologix Ethernet 5.04.00 protocol. We want to be able to read and write using bit and integer tags (button with toggle tag on click for bits, analog numeric for integer), testing right now with B24:0/1 N15:0/0, an internal bit tag and N15:0.

We can read from and write to the integer address from the HMI, but can only read from the bit addresses on the HMI. The buttons do not toggle the PLC bits. If we run the project on the development PC we can read from and write to all of the above addresses. The internal bit tag works on both.

There is no com error on the HMI, and the comm error is not hidden in the project.

The HMI was previously used to interface to a Siemens S7-1200 via S7IsoTCP with no problems.

What could this be and how might we fix it?

Thanks,

Matt


 Profile  
 
 Post subject: Re: Micrologix Ethernet Problem
PostPosted: Fri Feb 08, 2013 8:59 am 

Joined: Tue Mar 13, 2012 9:53 am
Posts: 824

Offline
The T12C is a PC, and is running the exact same application that is running on your development PC. There is no difference between the two applications. I would double check your programs to make sure the one on your development PC and the one on your T12C are the same program.

If your application is complex, then try creating a very simple program that has only 1 button that toggles the bit.

_________________
Best Regards,
Mark Monroe

Beijer Electronics, Inc. | Applications Engineer


 Profile  
 
 Post subject: Re: Micrologix Ethernet Problem
PostPosted: Sat Feb 09, 2013 5:58 pm 

Joined: Tue Oct 30, 2012 8:33 pm
Posts: 15

Offline
Hi Mark,

Thank you for your message. The program I was using for testing was one with only the three PLC tags and one internal tag I mentioned, one screen with three buttons and a numeric entry field. Only the numeric entry and the internal tag worked. I have since tried:

-all valid permutations of BOOL, BIT and DEFAULT data types for the bit tags: All combinations worked on the development PC, none on the T12C.
-a Micrologix 1100 with onboard Ethernet/IP (to rule out any issues with the Ethernet to DF1 adaptor): Same result.
-the same program converted to T7A communicating with the Micrologix 1100: both development PC and HMI worked for bits and integers.
-The T7A communicating with the Micrologix 1500 via adaptor: Both development PC and HMI worked for bits and integers.
-another new program with only one tag (N15:0/0) and one button: Development PC worked, T12C did not.

The Micrologix Ethernet Driver is 5.04.00 in the development PC.

How do I double check the programs to make sure that they are the same? I have just been downloading from the development PC and allowing the program to run automatically.

There are differences between the output folder on the development PC and the Project folder in iX Developer Runtime 2 on the T12C.

the files app.config, axacropdf.dll, controls.xml, microsoft.practices.servicelocation.dll, and tahoma.ttf are in the output folder but not in the iX Developer Runtime 2 on the T12C.

-the controller1.cfg files are identical
-allen-bradley_micrologix_ethernet.pre2.dll are are both 5.4.01
-controllerruntimesettings.xml are identical
project2.exe.config files are identical.

I had installed Mozilla Thunderbird on the T12C, but have uninstalled it.

What else can I check? Again, no comm errors and the numeric entry has worked in all cases. I am stumped.

Thank you again for all of your assistance.

Matt


 Profile  
 
 Post subject: Re: Micrologix Ethernet Problem
PostPosted: Mon Feb 11, 2013 9:49 am 

Joined: Tue Mar 13, 2012 9:53 am
Posts: 824

Offline
Hi Matt,

I sent you a PM with the latest Runtime and iX Developer. The runtime between the PC and the panel may be different. iX Developer is not always 100% backward compatible as far as PC runtimes are concerned.

Regards,
Mark

_________________
Best Regards,
Mark Monroe

Beijer Electronics, Inc. | Applications Engineer


 Profile  
 
 Post subject: Re: Micrologix Ethernet Problem
PostPosted: Mon Feb 11, 2013 3:34 pm 

Joined: Tue Oct 30, 2012 8:33 pm
Posts: 15

Offline
Hi Mark,

Thank you again. That was the problem. It didn't make a difference with the Siemens driver, but it did with the A-B. It is working fine now.

Best regards,
Matt


 Profile  
 
 Post subject: Re: Micrologix Ethernet Problem
PostPosted: Mon Apr 08, 2013 11:04 am 

Joined: Mon Feb 04, 2013 3:45 pm
Posts: 3

Offline
I'm having the same problem with my project. Please explain how to update the program on the panel.

I know that my PC has the most recent IX software, but I don't know how to update the software on the IX panel itself.


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 7 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: