Welcome Guest ( Login | Register )



All times are UTC - 7 hours [ DST ]



Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: I can,t use Library Expressions like Bitoperators
PostPosted: Tue Jun 11, 2019 3:43 am 

Joined: Tue Jun 11, 2019 3:25 am
Posts: 3

Offline
These three pictures are my configuration. Is there any problem with my use?
Software version:2.40 sp2


Attachments:
3.PNG
3.PNG [ 151.54 KiB | Viewed 34 times ]
2.PNG
2.PNG [ 195.54 KiB | Viewed 34 times ]
1.PNG
1.PNG [ 278.54 KiB | Viewed 34 times ]
 Profile  
 
 Post subject: Re: I can,t use Library Expressions like Bitoperators
PostPosted: Wed Jun 12, 2019 1:55 pm 

Joined: Mon Jun 11, 2012 2:10 pm
Posts: 128

Offline
"(value & 0x1) == 0x1" returns a Boolean value of true or false. My guess is iX is not able to properly convert this back to an integer value and thus returns 0, hence why this value is always blue.

Try removing the == 0x1 portion so the bit0IsSet has the formula "value & 0x1". This will result in an integer value of 0 or 1.

For other bits, you can add a bit shift. Ex: bit1IsSet would have the formula "(value & 0x2) >> 1".

_________________
Adam M.
Controls Engineer
FlexEnergy


 Profile  
 
 Post subject: Re: I can,t use Library Expressions like Bitoperators
PostPosted: Wed Jun 12, 2019 7:16 pm 

Joined: Tue Jun 11, 2019 3:25 am
Posts: 3

Offline
Thanks for your answer,I later discovered that it can only be used on PCs and not on touch screens.


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron